re = /^[А-ЩЄЮІЇЯ][а-щьєюіїя']{1,}(-[А-ЩЄЮІЇЯ][а-щьєюіїя']{1,})? [А-ЩЄЮІЇЯ][а-щьєюіїя']{1,}(-[А-ЩЄЮІЇЯ][а-щьєюіїя']{1,})? [А-ЩЄЮІЇЯ][а-щьєюіїя']{1,}$/m
str = 'Прасько Орест Гнатович
Хуба-Буба Мар\'яна-Галина В\'ячеславівна
Хуба-Буба Мар\'яна-Галина В\'ячеславівна-Василівна'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end