const regex = /^[А-ЩЄЮІЇЯ][а-щьєюіїя']{1,}(-[А-ЩЄЮІЇЯ][а-щьєюіїя']{1,})? [А-ЩЄЮІЇЯ][а-щьєюіїя']{1,}(-[А-ЩЄЮІЇЯ][а-щьєюіїя']{1,})? [А-ЩЄЮІЇЯ][а-щьєюіїя']{1,}$/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[А-ЩЄЮІЇЯ][а-щьєюіїя\']{1,}(-[А-ЩЄЮІЇЯ][а-щьєюіїя\']{1,})? [А-ЩЄЮІЇЯ][а-щьєюіїя\']{1,}(-[А-ЩЄЮІЇЯ][а-щьєюіїя\']{1,})? [А-ЩЄЮІЇЯ][а-щьєюіїя\']{1,}$', 'gmu')
const str = `Прасько Орест Гнатович
Хуба-Буба Мар'яна-Галина В'ячеславівна
Хуба-Буба Мар'яна-Галина В'ячеславівна-Василівна`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}