$re = '/(?<!\* )(@\$[a-z]|@\\\\?[a-zA-Z])/m';
$str = '/**
* @param string $someParam comment
* @param $otherParam comment
*/
@function();
@\\function();
@$this->output();
@self::output();
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);