using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\* )(@\$[a-z]|@\\?[a-zA-Z])";
string input = @"/**
* @param string $someParam comment
* @param $otherParam comment
*/
@function();
@\function();
@$this->output();
@self::output();
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}