use strict;
my $str = 'YONHPX0020170607ed68000p2';
my $regex = qr/([A-Z]{1}0{7}|[A-Z]{2}0{6}|[A-Z]{3}0{5}|[A-Z]{4}0{4}|[A-Z]{5}0{3}|[A-Z]{6}0{2}|[A-Z]{7}0{1}|[A-Z]{8})([0-9]{8})([0-9a-z]{4})([1-9a-z]{1}[0-9a-z]{4}|0{1}[0-9a-z]{4}|0{2}[0-9a-z]{3}|0{3}[0-9a-z]{2}|0{4}[0-9a-z]{1})/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}