import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z]{1}0{7}|[A-Z]{2}0{6}|[A-Z]{3}0{5}|[A-Z]{4}0{4}|[A-Z]{5}0{3}|[A-Z]{6}0{2}|[A-Z]{7}0{1}|[A-Z]{8})([0-9]{8})([0-9a-z]{4})([1-9a-z]{1}[0-9a-z]{4}|0{1}[0-9a-z]{4}|0{2}[0-9a-z]{3}|0{3}[0-9a-z]{2}|0{4}[0-9a-z]{1})";
final String string = "YONHPX0020170607ed68000p2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}