$re = '/^[a-z0-9_]{1}[a-z0-9\-_–-]*(\.[a-z0-9\-_–-]+)*@[a-z0-9–-]{1}[a-z0-9\-_–-]*(\.[a-z0-9\-_–-]+)*\.[a-z]{2,4}$/';
$str = 'Vendortimeout@gmail.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);