import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z0-9_]{1}[a-z0-9\\-_–-]*(\\.[a-z0-9\\-_–-]+)*@[a-z0-9–-]{1}[a-z0-9\\-_–-]*(\\.[a-z0-9\\-_–-]+)*\\.[a-z]{2,4}$";
final String string = "Vendortimeout@gmail.com";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}