using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[Uu]\w{0,10}\s*[Mm]*\w{0,4}(\,)*\s*[Rr]*\w{0,3}\s*\w{0,1}\s*[Pp]*\w{0,9}\s\w{0,2}\s*[Ss]\w{0,2}\s*[Ff]\w{0,8}\s*[Xx]\w{0,5}\s*\w{0,2}\s*[Cc]*\w{0,9}";
string input = @"Universidad Mayor, Real y Pontificia de San Francisco Xavier de Chuquisaca
universidad mayor, real y pontificia de san francisco xavier de chuquisaca
USFX
usfx
Universidad San Francisco Xavier
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}