#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[Uu]\w{0,10}\s*[Mm]*\w{0,4}(\,)*\s*[Rr]*\w{0,3}\s*\w{0,1}\s*[Pp]*\w{0,9}\s\w{0,2}\s*[Ss]\w{0,2}\s*[Ff]\w{0,8}\s*[Xx]\w{0,5}\s*\w{0,2}\s*[Cc]*\w{0,9}"
Local $sString = "Universidad Mayor, Real y Pontificia de San Francisco Xavier de Chuquisaca" & @CRLF & _
"universidad mayor, real y pontificia de san francisco xavier de chuquisaca" & @CRLF & _
"USFX" & @CRLF & _
"usfx" & @CRLF & _
"Universidad San Francisco Xavier" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")