// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((\d+)(\.\d+)?([a-zA-Z]*)\s(\w*))+( X )?").unwrap();
let string = "Ice block - 20cm Diameter X 40cm Height (Picture) Also Available In Ice block - 20cm Diameter X 63cm Height. Ice block - 20cm Diameter X 80cm Height .
Glass Vase - 58.5cm Diameter X 60.5cm Width X 80cm Height. Vase Height - 46.5cm New Glass Vase decorative flower detail
(\\d+)(\\.\\d+)([a-zA-Z]*)\\s(\\w*)( X )(\\d+)(\\.\\d+)([a-zA-Z]*)\\s(\\w*)( X )(\\d+)([a-zA-Z]*)\\s(\\w*) - works for 3
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}