import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\d+)(\\.\\d+)?([a-zA-Z]*)\\s(\\w*))+( X )?";
final String string = "Ice block - 20cm Diameter X 40cm Height (Picture) Also Available In Ice block - 20cm Diameter X 63cm Height. Ice block - 20cm Diameter X 80cm Height .\n\n"
+ "Glass Vase - 58.5cm Diameter X 60.5cm Width X 80cm Height. Vase Height - 46.5cm New Glass Vase decorative flower detail\n\n"
+ "(\\d+)(\\.\\d+)([a-zA-Z]*)\\s(\\w*)( X )(\\d+)(\\.\\d+)([a-zA-Z]*)\\s(\\w*)( X )(\\d+)([a-zA-Z]*)\\s(\\w*) - works for 3\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}