# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\w\s(?P<type>\S+)\s(?P<name>\S+)\s(?P<model>\S+)\s(?P<code>\S+)\s(?P<serial_number>\S+)\s(?P<in_charge>\S+\s\S+\s\S+)"
test_str = ("X Маршрутизатор Cisco 892FSР\n"
"00206760\n"
"FGL174121B4\n"
"Иванов Иван Иванович\n\n\n"
"4 Маршрутизатор Huawei HYFSР23\n"
"00216760\n"
"2FGL174121B4\n"
"Петров Петр Петррович\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.