const regex = new RegExp('\\w\\s(?P<type>\\S+)\\s(?P<name>\\S+)\\s(?P<model>\\S+)\\s(?P<code>\\S+)\\s(?P<serial_number>\\S+)\\s(?P<in_charge>\\S+\\s\\S+\\s\\S+)', 'g')
const str = `X Маршрутизатор Cisco 892FSР
00206760
FGL174121B4
Иванов Иван Иванович
4 Маршрутизатор Huawei HYFSР23
00216760
2FGL174121B4
Петров Петр Петррович
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}