const regex = /^([^?#]+).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^?#]+).*', 'gm')
const str = `https://studio.grabyo.com/home.jsp#stream/fBCyXMbtgHQ/share
https://studio.grabyo.com/studiolibrary.jsp?channelId=hkWw8oRUtPA
https://studio.grabyo.com/trim.jsp?campaignId=AQiJBGfoaJs&streamId=TCiHdVdqoBe
https://studio.grabyo.com/studiolibrary.jsp?streamId=TCiHdVdqoBe&galleryId=AQiJBGfoaJs
https://studio.grabyo.com/studiolibrary.jsp?campaignId=qzNPNPKTmry
https://studio.grabyo.com/trim.jsp?channelId=1dnc0Cjw9Ze
https://studio.grabyo.com/trim.jsp?campaignId=AQiJBGfoaJs
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}