using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^?#]+).*";
string input = @"https://studio.grabyo.com/home.jsp#stream/fBCyXMbtgHQ/share
https://studio.grabyo.com/studiolibrary.jsp?channelId=hkWw8oRUtPA
https://studio.grabyo.com/trim.jsp?campaignId=AQiJBGfoaJs&streamId=TCiHdVdqoBe
https://studio.grabyo.com/studiolibrary.jsp?streamId=TCiHdVdqoBe&galleryId=AQiJBGfoaJs
https://studio.grabyo.com/studiolibrary.jsp?campaignId=qzNPNPKTmry
https://studio.grabyo.com/trim.jsp?channelId=1dnc0Cjw9Ze
https://studio.grabyo.com/trim.jsp?campaignId=AQiJBGfoaJs
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}