import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(VisibileWeb)( != true Or IsNull\\(\\[CampoDinam)([^.]*)";
final String string = "VisibileWeb != true Or IsNull([CampoDinam01.\n"
+ "VisibileWeb != true Or IsNull([CampoDinam02.\n"
+ "VisibileWeb != true Or IsNull([CampoDinam05.";
final String subst = "[CampoDinam$3.$1]$2$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}