package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(VisibileWeb)( != true Or IsNull\(\[CampoDinam)([^.]*)`)
var str = `VisibileWeb != true Or IsNull([CampoDinam01.
VisibileWeb != true Or IsNull([CampoDinam02.
VisibileWeb != true Or IsNull([CampoDinam05.`
var substitution = "[CampoDinam$3.$1]$2$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}