$re = '/(?:function\s+\w+\s*)\((.*)\)(?:(?:(?:\s*:\s*)(\w+.*)))/s';
$str = 'private static function parse(
strJson:String,
iStart:Int,
iEnd:Int) : Map<String,String>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);