import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:function\\s+\\w+\\s*)\\((.*)\\)(?:(?:(?:\\s*:\\s*)(\\w+.*)))";
final String string = "private static function parse(\n"
+ " strJson:String, \n"
+ " iStart:Int, \n"
+ " iEnd:Int) : Map<String,String>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}