using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(到|去)?#的?((旅游|游玩)?(攻略|景区|风景区|景点|地方|地点|地|周边游)|旅游|玩)$";
string input = @"
#怎么玩
#有哪里好玩的
#有哪里好玩
#什么好玩的
#哪儿好玩
#什么好玩的地方
#有什么好玩的
#有哪好玩的
#都有什么好玩的
#有什么好地方
#啥好玩的
#有什么可玩的
#有什么好玩的地
#有啥可玩的
#有哪好玩
#什么景点
#有什么好玩的呀
#有什么好玩
#有哪些好玩的
#有哪里好玩的地方
#有啥好玩的没
#都有哪些好玩的
#有什么风景区
#有什么好景点
#有什么好玩的阿
#有哪里好玩呀
#有什么好玩的地儿
#有什么地方去
#有什么好玩的没
#有啥好玩的不
#哪儿好玩儿
#有什么可玩儿的
#哪儿好玩呀
#有啥好玩的地方
#什么好玩的呀
#有什么好玩的地方
#有啥子好玩的
#什么好玩儿的
#都有什么景点
去#有什么好玩的地方
我想去#有什么好玩儿的
去#有什么好玩的呀
去#有什么好玩
去#旅游怎么样
去#玩什么
去#玩
去#玩怎么样
#去哪里好玩
#有什么玩的
#有好玩的么
#什么地方好玩
#攻略有吗
#好玩的地方有哪些
去#的攻略
#风景区
去#旅游
#周边游
#游玩攻略
#有什么可玩的
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}