#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(到|去)?#的?((旅游|游玩)?(攻略|景区|风景区|景点|地方|地点|地|周边游)|旅游|玩)$"
Local $sString = "" & @CRLF & _
"#怎么玩" & @CRLF & _
"#有哪里好玩的" & @CRLF & _
"#有哪里好玩" & @CRLF & _
"#什么好玩的" & @CRLF & _
"#哪儿好玩" & @CRLF & _
"#什么好玩的地方" & @CRLF & _
"#有什么好玩的" & @CRLF & _
"#有哪好玩的" & @CRLF & _
"#都有什么好玩的" & @CRLF & _
"#有什么好地方" & @CRLF & _
"#啥好玩的" & @CRLF & _
"#有什么可玩的" & @CRLF & _
"#有什么好玩的地" & @CRLF & _
"#有啥可玩的" & @CRLF & _
"#有哪好玩" & @CRLF & _
"#什么景点" & @CRLF & _
"#有什么好玩的呀" & @CRLF & _
"#有什么好玩" & @CRLF & _
"#有哪些好玩的" & @CRLF & _
"#有哪里好玩的地方" & @CRLF & _
"#有啥好玩的没" & @CRLF & _
"#都有哪些好玩的" & @CRLF & _
"#有什么风景区" & @CRLF & _
"#有什么好景点" & @CRLF & _
"#有什么好玩的阿" & @CRLF & _
"#有哪里好玩呀" & @CRLF & _
"#有什么好玩的地儿" & @CRLF & _
"#有什么地方去" & @CRLF & _
"#有什么好玩的没" & @CRLF & _
"#有啥好玩的不" & @CRLF & _
"#哪儿好玩儿" & @CRLF & _
"#有什么可玩儿的" & @CRLF & _
"#哪儿好玩呀" & @CRLF & _
"#有啥好玩的地方" & @CRLF & _
"#什么好玩的呀" & @CRLF & _
"#有什么好玩的地方" & @CRLF & _
"#有啥子好玩的" & @CRLF & _
"#什么好玩儿的" & @CRLF & _
"#都有什么景点" & @CRLF & _
"去#有什么好玩的地方" & @CRLF & _
"我想去#有什么好玩儿的" & @CRLF & _
"去#有什么好玩的呀" & @CRLF & _
"去#有什么好玩" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"去#旅游怎么样" & @CRLF & _
"去#玩什么" & @CRLF & _
"去#玩" & @CRLF & _
"去#玩怎么样" & @CRLF & _
"#去哪里好玩" & @CRLF & _
"#有什么玩的" & @CRLF & _
"#有好玩的么" & @CRLF & _
"#什么地方好玩" & @CRLF & _
"#攻略有吗" & @CRLF & _
"#好玩的地方有哪些" & @CRLF & _
"" & @CRLF & _
"去#的攻略" & @CRLF & _
"#风景区" & @CRLF & _
"去#旅游" & @CRLF & _
"#周边游" & @CRLF & _
"#游玩攻略" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"#有什么可玩的" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")