# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<(\/?)\w+:(\w+\/?) ?(\w+:\w+.*)?>"
test_str = ("<?xml version=\"1.0\" encoding=\"utf-8\"?>\n"
"<soap:Envelope xmlns:soap=\"http://schemas.xmlsoap.org/soap/envelope/\" xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\" xmlns:xsd=\"http://www.w3.org/2001/XMLSchema\">\n"
" <soap:Body>\n"
" <ConnectResponse xmlns=\"aa\">\n"
" <ConnectResult xmlns=\"bb\">\n"
" <RETURNS>\n"
" <STATUS>A92A7EBEE897499fA8B06D5FE94B8A30</STATUS>\n"
" <APIPAYLOAD>\n"
" <COMMAND>\n"
" <TRACKINGID mya=\"cc\">e3d1618b4b7847628b10d4a432ec9151</TRACKINGID>\n"
" </COMMAND>\n"
" </APIPAYLOAD>\n"
" </RETURNS>\n"
" </ConnectResult>\n"
" </ConnectResponse>\n"
" </soap:Body>\n"
"</soap:Envelope>")
subst = "<$1$2>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.