re = /(.*) ?\((.*)\) Režie: (\S\.(?: \S+){1,2})(?: Hrají: )? ?(.*?)(?: http.*)?$/
str = 'fantasy/komed. (ČR) Režie: J. Strach Hrají: I. Trojan, J. Dvořák, V. Kerekesová'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end