$re = '/(.*) ?\((.*)\) Režie: (\S\.(?: \S+){1,2})(?: Hrají: )? ?(.*?)(?: http.*)?$/';
$str = 'fantasy/komed. (ČR) Režie: J. Strach Hrají: I. Trojan, J. Dvořák, V. Kerekesová';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);