$re = '/[;}{]{1}\n{1}[^\S\r\n]*\/\//m';
$str = 'test;
//comment with no newline between
test;
//comment with newline between';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);