import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[;\\}\\{]{1}\\n{1}[^\\S\\r\\n]*\\/\\/";
final String string = "test;\n"
+ " //comment with no newline between\n\n\n"
+ "test;\n\n"
+ " //comment with newline between";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}