re = /^([a-zA-Z0-9_\-\.]+)@([a-zA-Z0-9_\-]+)(\.[a-zA-Z]{2,5}){1,2}$/m
str = 'test-1@me.com
m_f@me.com.co
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end