package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-zA-Z0-9_\-\.]+)@([a-zA-Z0-9_\-]+)(\.[a-zA-Z]{2,5}){1,2}$`)
var str = `test-1@me.com
m_f@me.com.co
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}