const regex = new RegExp('^(.*?)/(.*?)?\\s(.*?)\\s(.*?)\\s', 'g')
const str = `libmono-system-xml4.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]
usbmuxd/kali-rolling,now 1.1.0-2+b1 amd64 [installed,automatic]
usbutils/kali-rolling,now 1:007-4 amd64 [installed]
util-linux/kali-rolling,now 2.28-6 amd64 [installed]
uuid-runtime/kali-rolling,now 2.28-6 amd64 [installed,automatic]
va-driver-all/kali-rolling,now 1.7.1-2 amd64 [installed,automatic]
vboot-kernel-utils/kali-rolling,now 0~R52-8350.B-1 amd64 [installed,automatic]
vboot-utils/kali-rolling,now 0~R52-8350.B-1 amd64 [installed,automatic]
vdpau-driver-all/kali-rolling,now 1.1.1-3 amd64 [installed,automatic]
libhttpclient-java/now 4.3.3-1 all [installed,local]
libhttpcore-java/now 4.3.2-2 all [installed,local]
libhwloc-dev/now 1.8-1ubuntu1.14.04.1 amd64 [installed,local]
libhwloc-plugins/now 1.8-1ubuntu1.14.04.1 amd64 [installed,local]
libhwloc5/now 1.8-1ubuntu1.14.04.1 amd64 [installed,local]
libhx509-5-heimdal/now 1.6~git20131207+dfsg-1ubuntu1.1 amd64 [installed,local]
libibverbs-dev/now 1.1.7-1ubuntu1.1 amd64 [installed,local]
libibverbs1/now 1.1.7-1ubuntu1.1 amd64 [installed,local]
libice-dev/now 2:1.0.8-2 amd64 [installed,local]
libice6/now 2:1.0.8-2 amd64 [installed,local]
libicu-dev/now 52.1-3ubuntu0.4 amd64 [installed,local]
libicu52/now 52.1-3ubuntu0.4 amd64 [installed,local]
libid3tag0/now 0.15.1b-10ubuntu1 amd64 [installed,local]
libidl-common/now 0.8.14-0.2ubuntu4 all [installed,local]
libidl0/now 0.8.14-0.2ubuntu4 amd64 [installed,local]
libidn11/now 1.28-1ubuntu2 amd64 [installed,local]
libieee1284-3/now 0.2.11-12 amd64 [installed,local]
libmono-system-windows4.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]
libmono-system-xaml4.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]
libmono-system-xml-linq4.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]
libmono-system-xml-serialization4.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]
libmono-system2.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]
libmono-system4.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]
libmono-tasklets2.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]
libmono-tasklets4.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]
libmono-wcf3.0a-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]
libmono-web4.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]
libmono-webbrowser2.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]
libmono-webbrowser4.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]
libmono-webmatrix-data4.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]
libmono-windowsbase3.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]
nginx/now 1.4.6-1ubuntu3.3 all [installed,local]
nginx-common/now 1.4.6-1ubuntu3.3 all [installed,local]
nginx-core/now 1.4.6-1ubuntu3.3 amd64 [installed,local]
novnc/now 1:0.4+dfsg+1+20131010+gitf68af8af3d-2 all [installed,local]
ntfs-3g/now 1:2013.1.13AR.1-2ubuntu2 amd64 [installed,local]
ntpdate/now 1:4.2.6.p5+dfsg-3ubuntu2.14.04.6 amd64 [installed,local]
ocl-icd-libopencl1/now 2.1.3-4 amd64 [installed,local]
openjdk-7-doc/now 7u91-2.6.3-0ubuntu0.14.04.1 all [installed,local]
openjdk-7-jdk/now 7u91-2.6.3-0ubuntu0.14.04.1 amd64 [installed,local]
openjdk-7-jre/now 7u91-2.6.3-0ubuntu0.14.04.1 amd64 [installed,local]
openjdk-7-jre-headless/now 7u91-2.6.3-0ubuntu0.14.04.1 amd64 [installed,local]
openmpi-bin/now 1.6.5-8 amd64 [installed,local]
openmpi-common/now 1.6.5-8 all [installed,local]
openssh-client/now 1:6.6p1-2ubuntu2.3 amd64 [installed,local]
openssl/now 1.0.1f-1ubuntu2.16 amd64 [installed,local]
parallel/now 20130922-1 all [installed,local]
parted/now 2.3-19ubuntu1.14.04.1 amd64 [installed,local]
passwd/now 1:4.1.5.1-1ubuntu9.1 amd64 [installed,local]
patch/now 2.7.1-4ubuntu2.3 amd64 [installed,local]
perl/now 5.18.2-2ubuntu1 amd64 [installed,local]
perl-base/now 5.18.2-2ubuntu1 amd64 [installed,local]
perl-modules/now 5.18.2-2ubuntu1 all [installed,local]
pgf/now 2.10-1 all [installed,local]
php-gettext/now 1.0.11-1 all [installed,local]
php-pear/now 5.5.9+dfsg-1ubuntu4.14 all [installed,local]
php5/now 5.5.9+dfsg-1ubuntu4.14 all [installed,local]
php5-cli/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]
php5-common/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]
php5-curl/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]
php5-dev/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]
php5-fpm/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]
php5-gd/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]
php5-intl/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]
php5-json/now 1.3.2-2build1 amd64 [installed,local]
php5-mcrypt/now 5.4.6-0ubuntu5 amd64 [installed,local]
php5-mysqlnd/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]
php5-pgsql/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]
php5-readline/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]
php5-sqlite/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]
php5-tidy/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]
php5-xmlrpc/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]
php5-xsl/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]
phpmyadmin/now 4:4.0.10-1 all [installed,local]
phppgadmin/now 5.1-1 all [installed,local]
pkg-config/now 0.26-1ubuntu4 amd64 [installed,local]
pkg-php-tools/now 1.11 all [installed,local]
plymouth/now 0.8.8-0ubuntu17.1 amd64 [installed,local]
po-debconf/now 1.0.16+nmu2ubuntu1 all [installed,local]
policykit-1/now 0.105-4ubuntu3.14.04.1 amd64 [installed,local]
policykit-1-gnome/now 0.105-1ubuntu4 amd64 [installed,local]
poppler-data/now 0.4.6-4 all [installed,local]
postgresql-9.3/now 9.3.10-0ubuntu0.14.04 amd64 [installed,local]
postgresql-client-9.3/now 9.3.10-0ubuntu0.14.04 amd64 [installed,local]
postgresql-client-common/now 154ubuntu1 all [installed,local]
postgresql-common/now 154ubuntu1 all [installed,local]
postgresql-doc/now 9.3+154ubuntu1 all [installed,local]
postgresql-doc-9.3/now 9.3.10-0ubuntu0.14.04 all [installed,local]
procps/now 1:3.3.9-1ubuntu2.2 amd64 [installed,local]
prosper/now 1.00.4+cvs.2007.05.01-4 all [installed,local]
ps2eps/now 1.68-1build1 amd64 [installed,local]
psmisc/now 22.20-1ubuntu2 amd64 [installed,local]
python/now 2.7.5-5ubuntu3 amd64 [installed,local]
python-amqp/now 1.3.3-1ubuntu1.1 all [installed,local]
python-amqplib/now 1.0.2-1 all [installed,local]
python-anyjson/now 0.3.3-1build1 all [installed,local]
python-apt/now 0.9.3.5ubuntu2 amd64 [installed,local]
python-apt-common/now 0.9.3.5ubuntu2 all [installed,local]
python-babel/now 1.3+dfsg.1-2ubuntu2 all [installed,local]
python-babel-localedata/now 1.3+dfsg.1-2ubuntu2 all [installed,local]
python-boto/now 2.20.1-2ubuntu2 all [installed,local]
python-bzrlib/now 2.6.0+bzr6593-1ubuntu1.1 amd64 [installed,local]
python-cairo/now 1.8.8-1ubuntu5 amd64 [installed,local]
python-chardet/now 2.0.1-2build2 all [installed,local]
python-chardet-whl/now 2.2.1-2~ubuntu1 all [installed,local]
python-cinderclient/now 1:1.0.8-0ubuntu2 all [installed,local]
python-cliff/now 1.4.5-1ubuntu2 all [installed,local]
python-cliff-doc/now 1.4.5-1ubuntu2 all [installed,local]
python-cmd2/now 0.6.7-2fakesync1build1 all [installed,local]
python-colorama/now 0.2.5-0.1ubuntu2 all [installed,local]
python-colorama-whl/now 0.2.5-0.1ubuntu2 all [installed,local]
python-configobj/now 4.7.2+ds-5build1 all [installed,local]
python-crypto/now 2.6.1-4build1 amd64 [installed,local]
python-dateutil/now 1.5+dfsg-1ubuntu1 all [installed,local]
python-dbus/now 1.2.0-2build2 amd64 [installed,local]
python-dbus-dev/now 1.2.0-2build2 all [installed,local]
python-decorator/now 3.4.0-2build1 all [installed,local]
python-dev/now 2.7.5-5ubuntu3 amd64 [installed,local]
python-distlib/now 0.1.8-1ubuntu1 all [installed,local]
python-distlib-whl/now 0.1.8-1ubuntu1 all [installed,local]
python-dns/now 2.3.6-3 all [installed,local]
python-eventlet/now 0.13.0-1ubuntu2.3 all [installed,local]
x11proto-xext-dev/now 7.3.0-1 all [installed,local]
x11vnc/now 0.9.13-1.1 amd64 [installed,local]
x11vnc-data/now 0.9.13-1.1 all [installed,local]
xauth/now 1:1.0.7-1ubuntu1 amd64 [installed,local]
xbitmaps/now 1.1.1-2 all [installed,local]
xdg-utils/now 1.1.0~rc1-2ubuntu7.1 all [installed,local]
xfonts-base/now 1:1.0.3 all [installed,local]
xfonts-encodings/now 1:1.0.4-1ubuntu1 all [installed,local]
xfonts-terminus/now 4.38-1fakesync1 all [installed,local]
xfonts-utils/now 1:7.7+1 amd64 [installed,local]
xkb-data/now 2.10.1-1ubuntu1 all [installed,local]
xml-core/now 0.13+nmu2 all [installed,local]
xorg-sgml-doctools/now 1:1.11-1 all [installed,local]
xserver-common/now 2:1.15.1-0ubuntu2.7 all [installed,local]
xsltproc/now 1.1.28-2build1 amd64 [installed,local]
xterm/now 297-1ubuntu1 amd64 [installed,local]
xtrans-dev/now 1.3.5-1~ubuntu14.04.1 all [installed,local]
xul-ext-ubufox/now 3.2-0ubuntu0.14.04.1 all [installed,local]
xvfb/now 2:1.15.1-0ubuntu2.7 amd64 [installed,local]
xz-utils/now 5.1.1alpha+20120614-2ubuntu2 amd64 [installed,local]
zip/now 3.0-8 amd64 [installed,local]
zlib1g/now 1:1.2.8.dfsg-1ubuntu1 amd64 [installed,local]
zlib1g-dev/now 1:1.2.8.dfsg-1ubuntu1 amd64 [installed,local]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}