#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(.*?)/(.*?)?\s(.*?)\s(.*?)\s"
Local $sString = "libmono-system-xml4.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]" & @CRLF & _
"" & @CRLF & _
"usbmuxd/kali-rolling,now 1.1.0-2+b1 amd64 [installed,automatic]" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"usbutils/kali-rolling,now 1:007-4 amd64 [installed]" & @CRLF & _
"util-linux/kali-rolling,now 2.28-6 amd64 [installed]" & @CRLF & _
"uuid-runtime/kali-rolling,now 2.28-6 amd64 [installed,automatic]" & @CRLF & _
"va-driver-all/kali-rolling,now 1.7.1-2 amd64 [installed,automatic]" & @CRLF & _
"vboot-kernel-utils/kali-rolling,now 0~R52-8350.B-1 amd64 [installed,automatic]" & @CRLF & _
"vboot-utils/kali-rolling,now 0~R52-8350.B-1 amd64 [installed,automatic]" & @CRLF & _
"vdpau-driver-all/kali-rolling,now 1.1.1-3 amd64 [installed,automatic]" & @CRLF & _
"libhttpclient-java/now 4.3.3-1 all [installed,local]" & @CRLF & _
"libhttpcore-java/now 4.3.2-2 all [installed,local]" & @CRLF & _
"libhwloc-dev/now 1.8-1ubuntu1.14.04.1 amd64 [installed,local]" & @CRLF & _
"libhwloc-plugins/now 1.8-1ubuntu1.14.04.1 amd64 [installed,local]" & @CRLF & _
"libhwloc5/now 1.8-1ubuntu1.14.04.1 amd64 [installed,local]" & @CRLF & _
"libhx509-5-heimdal/now 1.6~git20131207+dfsg-1ubuntu1.1 amd64 [installed,local]" & @CRLF & _
"libibverbs-dev/now 1.1.7-1ubuntu1.1 amd64 [installed,local]" & @CRLF & _
"libibverbs1/now 1.1.7-1ubuntu1.1 amd64 [installed,local]" & @CRLF & _
"libice-dev/now 2:1.0.8-2 amd64 [installed,local]" & @CRLF & _
"libice6/now 2:1.0.8-2 amd64 [installed,local]" & @CRLF & _
"libicu-dev/now 52.1-3ubuntu0.4 amd64 [installed,local]" & @CRLF & _
"libicu52/now 52.1-3ubuntu0.4 amd64 [installed,local]" & @CRLF & _
"libid3tag0/now 0.15.1b-10ubuntu1 amd64 [installed,local]" & @CRLF & _
"libidl-common/now 0.8.14-0.2ubuntu4 all [installed,local]" & @CRLF & _
"libidl0/now 0.8.14-0.2ubuntu4 amd64 [installed,local]" & @CRLF & _
"libidn11/now 1.28-1ubuntu2 amd64 [installed,local]" & @CRLF & _
"libieee1284-3/now 0.2.11-12 amd64 [installed,local]" & @CRLF & _
"libmono-system-windows4.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]" & @CRLF & _
"libmono-system-xaml4.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]" & @CRLF & _
"libmono-system-xml-linq4.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]" & @CRLF & _
"libmono-system-xml-serialization4.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]" & @CRLF & _
"" & @CRLF & _
"libmono-system2.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]" & @CRLF & _
"libmono-system4.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]" & @CRLF & _
"libmono-tasklets2.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]" & @CRLF & _
"libmono-tasklets4.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]" & @CRLF & _
"libmono-wcf3.0a-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]" & @CRLF & _
"libmono-web4.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]" & @CRLF & _
"libmono-webbrowser2.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]" & @CRLF & _
"libmono-webbrowser4.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]" & @CRLF & _
"libmono-webmatrix-data4.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]" & @CRLF & _
"libmono-windowsbase3.0-cil/now 3.2.8+dfsg-4ubuntu1.1 all [installed,local]" & @CRLF & _
"nginx/now 1.4.6-1ubuntu3.3 all [installed,local]" & @CRLF & _
"nginx-common/now 1.4.6-1ubuntu3.3 all [installed,local]" & @CRLF & _
"nginx-core/now 1.4.6-1ubuntu3.3 amd64 [installed,local]" & @CRLF & _
"novnc/now 1:0.4+dfsg+1+20131010+gitf68af8af3d-2 all [installed,local]" & @CRLF & _
"ntfs-3g/now 1:2013.1.13AR.1-2ubuntu2 amd64 [installed,local]" & @CRLF & _
"ntpdate/now 1:4.2.6.p5+dfsg-3ubuntu2.14.04.6 amd64 [installed,local]" & @CRLF & _
"ocl-icd-libopencl1/now 2.1.3-4 amd64 [installed,local]" & @CRLF & _
"openjdk-7-doc/now 7u91-2.6.3-0ubuntu0.14.04.1 all [installed,local]" & @CRLF & _
"openjdk-7-jdk/now 7u91-2.6.3-0ubuntu0.14.04.1 amd64 [installed,local]" & @CRLF & _
"openjdk-7-jre/now 7u91-2.6.3-0ubuntu0.14.04.1 amd64 [installed,local]" & @CRLF & _
"openjdk-7-jre-headless/now 7u91-2.6.3-0ubuntu0.14.04.1 amd64 [installed,local]" & @CRLF & _
"openmpi-bin/now 1.6.5-8 amd64 [installed,local]" & @CRLF & _
"openmpi-common/now 1.6.5-8 all [installed,local]" & @CRLF & _
"openssh-client/now 1:6.6p1-2ubuntu2.3 amd64 [installed,local]" & @CRLF & _
"openssl/now 1.0.1f-1ubuntu2.16 amd64 [installed,local]" & @CRLF & _
"parallel/now 20130922-1 all [installed,local]" & @CRLF & _
"parted/now 2.3-19ubuntu1.14.04.1 amd64 [installed,local]" & @CRLF & _
"passwd/now 1:4.1.5.1-1ubuntu9.1 amd64 [installed,local]" & @CRLF & _
"patch/now 2.7.1-4ubuntu2.3 amd64 [installed,local]" & @CRLF & _
"perl/now 5.18.2-2ubuntu1 amd64 [installed,local]" & @CRLF & _
"perl-base/now 5.18.2-2ubuntu1 amd64 [installed,local]" & @CRLF & _
"perl-modules/now 5.18.2-2ubuntu1 all [installed,local]" & @CRLF & _
"pgf/now 2.10-1 all [installed,local]" & @CRLF & _
"php-gettext/now 1.0.11-1 all [installed,local]" & @CRLF & _
"php-pear/now 5.5.9+dfsg-1ubuntu4.14 all [installed,local]" & @CRLF & _
"php5/now 5.5.9+dfsg-1ubuntu4.14 all [installed,local]" & @CRLF & _
"php5-cli/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]" & @CRLF & _
"php5-common/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]" & @CRLF & _
"php5-curl/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]" & @CRLF & _
"php5-dev/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]" & @CRLF & _
"php5-fpm/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]" & @CRLF & _
"php5-gd/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]" & @CRLF & _
"php5-intl/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]" & @CRLF & _
"php5-json/now 1.3.2-2build1 amd64 [installed,local]" & @CRLF & _
"php5-mcrypt/now 5.4.6-0ubuntu5 amd64 [installed,local]" & @CRLF & _
"php5-mysqlnd/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]" & @CRLF & _
"php5-pgsql/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]" & @CRLF & _
"php5-readline/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]" & @CRLF & _
"php5-sqlite/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]" & @CRLF & _
"php5-tidy/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]" & @CRLF & _
"php5-xmlrpc/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]" & @CRLF & _
"php5-xsl/now 5.5.9+dfsg-1ubuntu4.14 amd64 [installed,local]" & @CRLF & _
"phpmyadmin/now 4:4.0.10-1 all [installed,local]" & @CRLF & _
"phppgadmin/now 5.1-1 all [installed,local]" & @CRLF & _
"pkg-config/now 0.26-1ubuntu4 amd64 [installed,local]" & @CRLF & _
"pkg-php-tools/now 1.11 all [installed,local]" & @CRLF & _
"plymouth/now 0.8.8-0ubuntu17.1 amd64 [installed,local]" & @CRLF & _
"po-debconf/now 1.0.16+nmu2ubuntu1 all [installed,local]" & @CRLF & _
"policykit-1/now 0.105-4ubuntu3.14.04.1 amd64 [installed,local]" & @CRLF & _
"policykit-1-gnome/now 0.105-1ubuntu4 amd64 [installed,local]" & @CRLF & _
"poppler-data/now 0.4.6-4 all [installed,local]" & @CRLF & _
"postgresql-9.3/now 9.3.10-0ubuntu0.14.04 amd64 [installed,local]" & @CRLF & _
"postgresql-client-9.3/now 9.3.10-0ubuntu0.14.04 amd64 [installed,local]" & @CRLF & _
"postgresql-client-common/now 154ubuntu1 all [installed,local]" & @CRLF & _
"postgresql-common/now 154ubuntu1 all [installed,local]" & @CRLF & _
"postgresql-doc/now 9.3+154ubuntu1 all [installed,local]" & @CRLF & _
"postgresql-doc-9.3/now 9.3.10-0ubuntu0.14.04 all [installed,local]" & @CRLF & _
"procps/now 1:3.3.9-1ubuntu2.2 amd64 [installed,local]" & @CRLF & _
"prosper/now 1.00.4+cvs.2007.05.01-4 all [installed,local]" & @CRLF & _
"ps2eps/now 1.68-1build1 amd64 [installed,local]" & @CRLF & _
"psmisc/now 22.20-1ubuntu2 amd64 [installed,local]" & @CRLF & _
"python/now 2.7.5-5ubuntu3 amd64 [installed,local]" & @CRLF & _
"python-amqp/now 1.3.3-1ubuntu1.1 all [installed,local]" & @CRLF & _
"python-amqplib/now 1.0.2-1 all [installed,local]" & @CRLF & _
"python-anyjson/now 0.3.3-1build1 all [installed,local]" & @CRLF & _
"python-apt/now 0.9.3.5ubuntu2 amd64 [installed,local]" & @CRLF & _
"python-apt-common/now 0.9.3.5ubuntu2 all [installed,local]" & @CRLF & _
"python-babel/now 1.3+dfsg.1-2ubuntu2 all [installed,local]" & @CRLF & _
"python-babel-localedata/now 1.3+dfsg.1-2ubuntu2 all [installed,local]" & @CRLF & _
"python-boto/now 2.20.1-2ubuntu2 all [installed,local]" & @CRLF & _
"python-bzrlib/now 2.6.0+bzr6593-1ubuntu1.1 amd64 [installed,local]" & @CRLF & _
"python-cairo/now 1.8.8-1ubuntu5 amd64 [installed,local]" & @CRLF & _
"python-chardet/now 2.0.1-2build2 all [installed,local]" & @CRLF & _
"python-chardet-whl/now 2.2.1-2~ubuntu1 all [installed,local]" & @CRLF & _
"python-cinderclient/now 1:1.0.8-0ubuntu2 all [installed,local]" & @CRLF & _
"python-cliff/now 1.4.5-1ubuntu2 all [installed,local]" & @CRLF & _
"python-cliff-doc/now 1.4.5-1ubuntu2 all [installed,local]" & @CRLF & _
"python-cmd2/now 0.6.7-2fakesync1build1 all [installed,local]" & @CRLF & _
"python-colorama/now 0.2.5-0.1ubuntu2 all [installed,local]" & @CRLF & _
"python-colorama-whl/now 0.2.5-0.1ubuntu2 all [installed,local]" & @CRLF & _
"python-configobj/now 4.7.2+ds-5build1 all [installed,local]" & @CRLF & _
"python-crypto/now 2.6.1-4build1 amd64 [installed,local]" & @CRLF & _
"python-dateutil/now 1.5+dfsg-1ubuntu1 all [installed,local]" & @CRLF & _
"python-dbus/now 1.2.0-2build2 amd64 [installed,local]" & @CRLF & _
"python-dbus-dev/now 1.2.0-2build2 all [installed,local]" & @CRLF & _
"python-decorator/now 3.4.0-2build1 all [installed,local]" & @CRLF & _
"python-dev/now 2.7.5-5ubuntu3 amd64 [installed,local]" & @CRLF & _
"python-distlib/now 0.1.8-1ubuntu1 all [installed,local]" & @CRLF & _
"python-distlib-whl/now 0.1.8-1ubuntu1 all [installed,local]" & @CRLF & _
"python-dns/now 2.3.6-3 all [installed,local]" & @CRLF & _
"python-eventlet/now 0.13.0-1ubuntu2.3 all [installed,local]" & @CRLF & _
"x11proto-xext-dev/now 7.3.0-1 all [installed,local]" & @CRLF & _
"x11vnc/now 0.9.13-1.1 amd64 [installed,local]" & @CRLF & _
"x11vnc-data/now 0.9.13-1.1 all [installed,local]" & @CRLF & _
"xauth/now 1:1.0.7-1ubuntu1 amd64 [installed,local]" & @CRLF & _
"xbitmaps/now 1.1.1-2 all [installed,local]" & @CRLF & _
"xdg-utils/now 1.1.0~rc1-2ubuntu7.1 all [installed,local]" & @CRLF & _
"xfonts-base/now 1:1.0.3 all [installed,local]" & @CRLF & _
"xfonts-encodings/now 1:1.0.4-1ubuntu1 all [installed,local]" & @CRLF & _
"xfonts-terminus/now 4.38-1fakesync1 all [installed,local]" & @CRLF & _
"xfonts-utils/now 1:7.7+1 amd64 [installed,local]" & @CRLF & _
"xkb-data/now 2.10.1-1ubuntu1 all [installed,local]" & @CRLF & _
"xml-core/now 0.13+nmu2 all [installed,local]" & @CRLF & _
"xorg-sgml-doctools/now 1:1.11-1 all [installed,local]" & @CRLF & _
"xserver-common/now 2:1.15.1-0ubuntu2.7 all [installed,local]" & @CRLF & _
"xsltproc/now 1.1.28-2build1 amd64 [installed,local]" & @CRLF & _
"xterm/now 297-1ubuntu1 amd64 [installed,local]" & @CRLF & _
"xtrans-dev/now 1.3.5-1~ubuntu14.04.1 all [installed,local]" & @CRLF & _
"xul-ext-ubufox/now 3.2-0ubuntu0.14.04.1 all [installed,local]" & @CRLF & _
"xvfb/now 2:1.15.1-0ubuntu2.7 amd64 [installed,local]" & @CRLF & _
"xz-utils/now 5.1.1alpha+20120614-2ubuntu2 amd64 [installed,local]" & @CRLF & _
"zip/now 3.0-8 amd64 [installed,local]" & @CRLF & _
"zlib1g/now 1:1.2.8.dfsg-1ubuntu1 amd64 [installed,local]" & @CRLF & _
"zlib1g-dev/now 1:1.2.8.dfsg-1ubuntu1 amd64 [installed,local]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")