package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^0((13|2[2-4]|3|4[05-8]|5[05]|6[24-689]|8[2468]|9[235-7])\d{7}|1[0125]\d{8})$`)
var str = `0237802486
0237794824
0225292828
0222803359
0244672263
0683362700
0927922556
01020304050
01177777777
01234567890
01018028445
01015030111`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}