#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^0((13|2[2-4]|3|4[05-8]|5[05]|6[24-689]|8[2468]|9[235-7])\d{7}|1[0125]\d{8})$"
Local $sString = "0237802486" & @CRLF & _
"0237794824" & @CRLF & _
"0225292828" & @CRLF & _
"0222803359" & @CRLF & _
"0244672263" & @CRLF & _
"0683362700" & @CRLF & _
"0927922556" & @CRLF & _
"01020304050" & @CRLF & _
"01177777777" & @CRLF & _
"01234567890" & @CRLF & _
"01018028445" & @CRLF & _
"01015030111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")