// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(?:ts(?:m(?:09|1[0-9]|20))?|edtd\-ts)\.eset\.com$").unwrap();
let string = "tsm09.eset.com
tsm10.eset.com
tsm11.eset.com
tsm12.eset.com
tsm13.eset.com
tsm14.eset.com
tsm15.eset.com
tsm16.eset.com
tsm17.eset.com
tsm18.eset.com
tsm19.eset.com
tsm20.eset.com
ts.eset.com
edtd-ts.eset.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}