const regex = /^(?:ts(?:m(?:09|1[0-9]|20))?|edtd\-ts)\.eset\.com$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:ts(?:m(?:09|1[0-9]|20))?|edtd\\-ts)\\.eset\\.com$', 'gmi')
const str = `tsm09.eset.com
tsm10.eset.com
tsm11.eset.com
tsm12.eset.com
tsm13.eset.com
tsm14.eset.com
tsm15.eset.com
tsm16.eset.com
tsm17.eset.com
tsm18.eset.com
tsm19.eset.com
tsm20.eset.com
ts.eset.com
edtd-ts.eset.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}