$re = '/(h|l)?(\d)((l|m|cm)(?!\d))?/m';
$str = 'h1m2
h1cm2
h1l2
h1l2m';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);