const regex = /(h|l)?(\d)((l|m|cm)(?!\d))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(h|l)?(\\d)((l|m|cm)(?!\\d))?', 'gm')
const str = `h1m2
h1cm2
h1l2
h1l2m`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}