# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(NUMBER[(](\d{1,3},\d)[)])|(NUMBER[(]((\d{1,3})|(\d{1,3}[,]\d))[)]((?=\/DECIMAL)|(?=\/PERCENTAGE)).*)"
test_str = ("NUMBER(12)\n"
"NUMBER(12)/NUMBER\n"
"NUMBER(1)\n"
"NUMBER(1)/NUMBER\n"
"(100)\n"
"DATATYPE=NUMBER\n"
"NUMBER\n"
"NUMBER()\n"
"NUMBER(10,2)/PERCENTAGE\n"
"NUMBER(12)/DECIMAL\n"
"NUMBER(12,4)\n"
"NUMBER(13,4)\n"
"NUMBER(15)/DECIMAL\n"
"NUMBER(15,2)\n"
"NUMBER(16)/DECIMAL\n"
"NUMBER(10,3)/DECIMAL\n"
"NUMBER(3)/DECIMAL\n"
"NUMBER(3)/PERCENTAGE\n"
"NUMBER(4)/DECIMAL\n"
"NUMBER(4,1)\n"
"NUMBER(4,2)\n"
"NUMBER(5)/DECIMAL\n"
"NUMBER(5)/PERCENTAGE\n"
"NUMBER(5,2)\n"
"NUMBER(5,2)/PERCENTAGE\n"
"NUMBER(6)/DECIMAL\n"
"NUMBER(7)/DECIMAL\n"
"NUMBER(8)/DECIMAL\n"
"NUMBER/\n"
"NUMBER/CURRENCY\n"
"NUMBER/DECIMAL\n"
"NUMBER/IFS CURRENCY\n"
"NUMBER/INVISIBLE\n"
"NUMBER/NUMBER\n"
"NUMBER/PERCENTAGE\n"
"NUMBER/UPPERCASE\n"
"NUMBER=\n"
"Number\n"
"number\n")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.