import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(NUMBER[(](\\d{1,3},\\d)[)])|(NUMBER[(]((\\d{1,3})|(\\d{1,3}[,]\\d))[)]((?=\\/DECIMAL)|(?=\\/PERCENTAGE)).*)";
final String string = "NUMBER(12)\n"
+ "NUMBER(12)/NUMBER\n"
+ "NUMBER(1)\n"
+ "NUMBER(1)/NUMBER\n"
+ "(100)\n"
+ "DATATYPE=NUMBER\n"
+ "NUMBER\n"
+ "NUMBER()\n"
+ "NUMBER(10,2)/PERCENTAGE\n"
+ "NUMBER(12)/DECIMAL\n"
+ "NUMBER(12,4)\n"
+ "NUMBER(13,4)\n"
+ "NUMBER(15)/DECIMAL\n"
+ "NUMBER(15,2)\n"
+ "NUMBER(16)/DECIMAL\n"
+ "NUMBER(10,3)/DECIMAL\n"
+ "NUMBER(3)/DECIMAL\n"
+ "NUMBER(3)/PERCENTAGE\n"
+ "NUMBER(4)/DECIMAL\n"
+ "NUMBER(4,1)\n"
+ "NUMBER(4,2)\n"
+ "NUMBER(5)/DECIMAL\n"
+ "NUMBER(5)/PERCENTAGE\n"
+ "NUMBER(5,2)\n"
+ "NUMBER(5,2)/PERCENTAGE\n"
+ "NUMBER(6)/DECIMAL\n"
+ "NUMBER(7)/DECIMAL\n"
+ "NUMBER(8)/DECIMAL\n"
+ "NUMBER/\n"
+ "NUMBER/CURRENCY\n"
+ "NUMBER/DECIMAL\n"
+ "NUMBER/IFS CURRENCY\n"
+ "NUMBER/INVISIBLE\n"
+ "NUMBER/NUMBER\n"
+ "NUMBER/PERCENTAGE\n"
+ "NUMBER/UPPERCASE\n"
+ "NUMBER=\n"
+ "Number\n"
+ "number\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}