// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([0-9A-F]{2}-){5}[0-9A-F]{2}$").unwrap();
let string = "Z1-1B-63-84-45-E6
not a MAC-48 address
00-1B-63-84-45-E6";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}