$re = '/^([0-9A-F]{2}-){5}[0-9A-F]{2}$/m';
$str = 'Z1-1B-63-84-45-E6
not a MAC-48 address
00-1B-63-84-45-E6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);