re = /(http(s?):\/\/)?(www\.)?dribbble\.([a-z])+\/([A-Za-z0-9]{1,})/i
str = 'https://dribbble.com/Shallowboy
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end