const regex = /(http(s?):\/\/)?(www\.)?dribbble\.([a-z])+\/([A-Za-z0-9]{1,})/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http(s?):\\\/\\\/)?(www\\.)?dribbble\\.([a-z])+\\\/([A-Za-z0-9]{1,})', 'i')
const str = `https://dribbble.com/Shallowboy
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}