// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^(https?:\/\/)?[0-9a-z-_]*(\.[0-9a-z-_]+)*(\.[a-z]+)+(\/[0-9a-z-_]*)*?\/?$").unwrap();
let string = "nearform.com
graphql-hooks.com
nearform.com/
www.nearform.com
www.nearform.com/
http://nearform.com
https://nearform.com/
http://www.nearform.com
https://github.nearform.com/graphql-hooks
https://www.fastify.io/
react-js.org
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}