#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(https?:\/\/)?[0-9a-z-_]*(\.[0-9a-z-_]+)*(\.[a-z]+)+(\/[0-9a-z-_]*)*?\/?$"
Local $sString = "nearform.com" & @CRLF & _
"graphql-hooks.com" & @CRLF & _
"nearform.com/" & @CRLF & _
"www.nearform.com" & @CRLF & _
"www.nearform.com/" & @CRLF & _
"http://nearform.com" & @CRLF & _
"https://nearform.com/" & @CRLF & _
"http://www.nearform.com" & @CRLF & _
"https://github.nearform.com/graphql-hooks" & @CRLF & _
"https://www.fastify.io/" & @CRLF & _
"react-js.org" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")