$re = '/^([A-Z]|[a-z]|\s)+(,\s*(Jr\.|Sr\.|[IV]*))?$/m';
$str = ' John Smith, Jr.
Winn Thomas
Mary 3llen Jones
Clyde Franklin, III
wallace firt, the second
wimbobimbo ff , VIVIVVVVIIIVIIVVI
s f asdf s dfFASFSf dsf saf sFD s faS fdy t sg , Sr.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);