#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([A-Z]|[a-z]|\s)+(,\s*(Jr\.|Sr\.|[IV]*))?$"
Local $sString = " John Smith, Jr." & @CRLF & _
"Winn Thomas" & @CRLF & _
" Mary 3llen Jones " & @CRLF & _
"Clyde Franklin, III" & @CRLF & _
"wallace firt, the second" & @CRLF & _
"wimbobimbo ff , VIVIVVVVIIIVIIVVI" & @CRLF & _
"s f asdf s dfFASFSf dsf saf sFD s faS fdy t sg , Sr."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")