const regex = /^(?:https?:\/\/)?(?:www\.)?(?:youtube\.com\/watch\?v=([a-zA-Z0-9_]+)|youtu\.be\/([a-zA-Z\d_]+))(?:&.*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:https?:\\\/\\\/)?(?:www\\.)?(?:youtube\\.com\\\/watch\\?v=([a-zA-Z0-9_]+)|youtu\\.be\\\/([a-zA-Z\\d_]+))(?:&.*)?$', 'gm')
const str = `http://www.youtube.com/watch?v=p72I7gRXpg
http://youtube.com/watch?v=bQVoAWSP7k4
http://www.youtube.com/watch?v=bQVoAWSP7k4
https://youtu.be/6WZoMAVCggM
http://www.youtube.com/watch?v=6WZoMAVCggM&
http://www.youtube.com/watch?v=bQVoAWSP7k4&feature=popular
http://www.youtube.com/watch?v=McNqjYiFmyQ&feature=related&bhablah
www.youtube.com/watch?v=McNqjYiFmyQ&feature=related&bhablah
youtu.be/6WZoMAVCggM
youtube.com/watch?v=bQVoAWSP7k4
http://youtube.com/watch?v=bQVoAWSP7k4
http://youtu.be/6WZoMAVCg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}