import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?:\\/\\/)?(?:www\\.)?(?:youtube\\.com\\/watch\\?v=([a-zA-Z0-9_]+)|youtu\\.be\\/([a-zA-Z\\d_]+))(?:&.*)?$";
final String string = "http://www.youtube.com/watch?v=p72I7gRXpg\n"
+ "http://youtube.com/watch?v=bQVoAWSP7k4\n"
+ "http://www.youtube.com/watch?v=bQVoAWSP7k4\n"
+ "https://youtu.be/6WZoMAVCggM\n"
+ "http://www.youtube.com/watch?v=6WZoMAVCggM&\n"
+ "http://www.youtube.com/watch?v=bQVoAWSP7k4&feature=popular\n"
+ "http://www.youtube.com/watch?v=McNqjYiFmyQ&feature=related&bhablah\n"
+ "www.youtube.com/watch?v=McNqjYiFmyQ&feature=related&bhablah\n"
+ "youtu.be/6WZoMAVCggM\n"
+ "youtube.com/watch?v=bQVoAWSP7k4\n"
+ "http://youtube.com/watch?v=bQVoAWSP7k4\n"
+ "http://youtu.be/6WZoMAVCg";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}