const regex = /\/\*(?:.|\n)*?GNU General Public License(?:.|\n)*?\*\/|\"use strict";/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/\\*(?:.|\\n)*?GNU General Public License(?:.|\\n)*?\\*\\\/|\\"use strict";', 'gm')
const str = `/*
* This file is part of OverPy (https://github.com/Zezombye/overpy).
* Copyright (c) 2019 Zezombye.
*
* This program is free software: you can redistribute it and/or modify
* it under the terms of the GNU General Public License as published by
* the Free Software Foundation, version 3.
*
* This program is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
*
* You should have received a copy of the GNU General Public License
* along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
"use strict";
astParsingFunctions["_&addToScore"] = function(content) {
if (enableOptimization) {
if (content.args[0].name === "__number__" && content.args[0].args[0].numValue === 0) {
return getAstForUselessInstruction();
}
}
return content;
}`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);